Service Alert: Anthology HR/Finance

Incident Report for St Marys College of Maryland

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 14:42 EDT

Monitoring

Anthology HR/Finance is now back online and available for use.

Our team will continue to monitor the system closely to ensure everything is functioning as expected.
Posted Jun 03, 2026 - 10:54 EDT

Identified

Anthology HR/Finance is currently undergoing scheduled updates and is temporarily unavailable. We expect service to be restored shortly.

We appreciate your patience and understanding while this maintenance is being completed.
Posted Jun 03, 2026 - 08:34 EDT
This incident affected: Anthology and Learning Management Platforms (Anthology Finance).